Decoder reads only "123"?

TwinDad May 19, 2018

  1. TwinDad

    TwinDad TrainBoard Member

    1,844
    550
    34
    I'm trying to help a friend set up a programming track with JMRI and Digitrax gear (DCS51 and PR4). I've been helping him over the phone, but will be going over to his place tomorrow.

    It sounds like he has everything set up correctly but when he tries to read this one particular decoder, all he gets is the value "123" no matter which CV he is reading. No error message from JMRI either.

    I haven't been able to tell if this is one particular decoder or all decoders. He also doesn't know exactly what decoder is installed, only that it's an Atlas loco that he bought at a trade show or swap meet.

    Has anyone seen this?

    I'm taking my own gear over, plus a "known good" locomotive, and see what's what, but I have almost no idea how this could be happening...
     
  2. RBrodzinsky

    RBrodzinsky Staff Member TrainBoard Supporter

    5,616
    2,640
    96
    It wasn’t 123, but I recently looked at an older Atlas that had the factory NCE decoder, and all it did was give a constant value no matter what I tried. Couldn’t reset it, but it would run, sort of. That loco now has an ESU LokSound 73100 in it.
     
    TwinDad likes this.
  3. ZFRANK

    ZFRANK TrainBoard Member

    923
    474
    25
    Try the Digitrax helpdesk.
     
  4. TwinDad

    TwinDad TrainBoard Member

    1,844
    550
    34
    Mystery solved.

    The JMRI programmer has a selector for which interface to use (like if you have both LocoNet and NCE connections). The interface selector was set to "Internal" instead of "LocoNet", so it was reading "123". When I switched the selector to "LocoNet", everything worked fine.

    The decoder turns out to be the factory QSI sound decoder for an HO Atlas MP15DC.
     

Share This Page