Ok, What have I missed ????

Discussion in 'DCC & Electronics' started by Carl Sowell, May 24, 2008.

  1. Carl Sowell

    Carl Sowell TrainBoard Supporter

    I put a micro tsunami in the tender of my KATO GS-4.
    It will not program. It just sits there with power in but nothing out. I am using a Digitrax Zephyr and have tried in OPS and PAGE mode. Nothing, it will not read or write cv's.

    What do I do next?

    Thanks in advance.
  2. Lownen

    Lownen TrainBoard Member

    How did you do the install? Did you follow this thread?

    KATO GS-4 Tsunami install Step by step! - TrainBoard.com

    If you've gotten all the connections correct, it sounds like you could have a bad decoder. However, you only mentioned trying to program, you said nothing about running. I am presuming that it also doesn't run. If it does run and you can't program, some of the newer decoders output enough current for the Zephyr to read CVs. You have to put a 1k ohm resistor across the programming track leads to get it to work. I've had to do this with both Digitrax and Lenz decoders.

  3. Carl Sowell

    Carl Sowell TrainBoard Supporter


    Yes, I followed that thread to a degree.
    I actually machined ( dremeled ) the wheel wells that caused problems so that I could use the motor feeds in the drawbar. Pretty neat design by KATO. I also, put Richmond Controls modules in for the backup light and in the boiler for mars and headlight. Realy easy to do and yes I have all the colors matched correctly.

    The decoder pilot light indicates that it is getting power, but nothing out. It will not run in dc or dcc. After checking on the net, I see that these sound decoders may need help on programming track.

    You say you used a 1K resistor and just laid it across the tracks?


    Pic is not the best, but you can see that there is plenty of room with the weight and cradle installed.
  4. Lownen

    Lownen TrainBoard Member

    Just laying it across the tracks didn't work for me... I had to put the resistor's leads in the screw down terminals with the track leads. But then it worked fine.

    Let us know if that works.

  5. AB&CRRone

    AB&CRRone TrainBoard Supporter

    My GS-4 with Tsunami installed accepts programming in OPS mode quite easily. And I reprogrammed the loco address on a programming track with no resistor. Both using Digitrax Zephyr. The only thing I can't do is read CV's.

    I would think you should be able to do the same if everything else is OK.

  6. Lownen

    Lownen TrainBoard Member


    You're probably correct. It sounds like a bad decoder, but I thought the resistor was worth a shot. By the way, if you try the resistor you should be able to read your CV's as it's the decoder's write current that's too low for the Zephyr to read without the resistor.
  7. TrainGuy

    TrainGuy TrainBoard Supporter Advertiser

    Did you test the decoder before you installed it in the tender?
    Be sure that your wheel contacts have not come out of their slots in the tender and that you do have continuity between the wheels and their respecive red and black wires.

    I would suggest that you check your contact points for the red and black pickup. Also make sure that you have the orange and gray wires isolated.
    You should not need a resistor across the red and black to program and the decoder should come to life as soon as power is applied. Also check to be sure that the Yellow/Green wire is hooked to the negative cap terminal and the blue is connected to the Positive.

    If this does not produce any sound or light remove the decoder and check it again out of the installation.
  8. Carl Sowell

    Carl Sowell TrainBoard Supporter


    To answer your question, no I did not test the decoder before connecting wires. I'm not sure how you do that. At any rate the wiring is correct. red/red, black/black, orange/orange and so on. the decoder is getting power as the pilot light comes on, the cap is charged. Just nothing out to speaker or to locomotive. I do not have it connected to loco as yet but have checked outputs with meter. Nada! I can not acquire the address, I can not read or write cv's. I know the Zephyer system is working because I checked it with two DSX decoders and all worked fine. ? ? ?
  9. mfm_37

    mfm_37 TrainBoard Member

    The following may or may not work depending on your decoder's problem. If it's actually faulty, no damage will be done.
    Programming any decoder in OPs mode will work but only if the actual address for the decoder is known. Since you can't read it and it's not responding to address 03, it's possible the decoder has some unknown address programmed.
    Here's a quick and dirty way of programming in OPS mode when the actual address isn't known.
    First remove all engines from the track except the one being programmed.
    Select address 00 on your Zephyr, turn throttle down to 0 but leave the direction switch in either forward or reverse.
    Press the Program button until OPS appears.
    Press the CV key once then select the Cv you would like to change. In this case use CV1.
    Press CV key again then select a two digit address to program with the key pad.
    Press CV-Wr and Cv1 will be programmed to the selected address.
    Press the CV key again and select CV29.
    Press Cv key again and select a value of 06 with the key pad.
    Press the CV-Wr button and CV 29 will be given a value of 06.

    Press EXIT and dispatch address 00.
    Select the address byou programmed and test the loco.

    All of the above will work on any NMRA decoder because they all respond to address 00. That's how command stations send an "all stop" message. I've never tried a reset using this method so can't say whether that will work.
    The biggest thing to remember is to remove all other engines from the track or they will be reprogrammed too.

    Martin Myers
  10. Carl Sowell

    Carl Sowell TrainBoard Supporter


    Thanks for the suggestion. It did not work. I believe the decoder is bad and will return it to Soundtraxx.

  11. dstuard

    dstuard TrainBoard Member

    I don't know about Tsunami's, but in most cases you need a load on the motor leads in order for the decoder to program, read back, etc. Either the motor itself or a 100 ohm 1 or 2 watt resistor should do.

    The meter by itself is too light a load to be recognized by the decoder.
  12. Carl Sowell

    Carl Sowell TrainBoard Supporter


    Thanks for the suggestion. I did try connecting the loco to tender. Nada, nothing. ????

Share This Page