Search is not working

vasilis Oct 8, 2018

  1. RBrodzinsky

    RBrodzinsky Staff Member TrainBoard Supporter

    5,126
    1,717
    81
    It came back Tuesday morning after the report, but, yes, it is down again. Grrrr
     
  2. bremner

    bremner Staff Member

    5,211
    2,852
    90
    Some function in the server is off...I reboot it and it works for a few hours.
     
  3. Hardcoaler

    Hardcoaler TrainBoard Member

    4,454
    7,786
    78
    Search remains kaput.
     
  4. Allegheny

    Allegheny TrainBoard Member

    114
    10
    19
    Still down as of Jan 17 at 1016 EST.
     
  5. Doug A.

    Doug A. TrainBoard Supporter

    3,443
    89
    51
    Trying to search for posted/started threads doesn't work...assume this is related to this issue.
     
  6. bremner

    bremner Staff Member

    5,211
    2,852
    90
    Ok, I have rebooted the server, that got the search function working. I then repaired the tables, checked and analyzed the tables...so far so good. At this point, the fun begins...raw numbers...the database has 223 tables, and is 1.8GiB in size. THIS IS A BIG DATABASE. When I attempted to optimize the database, phpmyadmin spun and loaded a 500 Internal Server Error, an error that the server and browser does not know what happened. My best guess is that it timed out. I then tried to optimize just the posts table, which is 80.5MiB by itself. This made MySQL crash. After restarting MySQL again, the site is upand the search is working again...for now.
     
    Doug A. likes this.
  7. bremner

    bremner Staff Member

    5,211
    2,852
    90
    And it is down again
     
  8. bremner

    bremner Staff Member

    5,211
    2,852
    90
    Found a php memory error in logs....increased php memory limit
     
  9. bremner

    bremner Staff Member

    5,211
    2,852
    90
    Search is up
     
  10. bremner

    bremner Staff Member

    5,211
    2,852
    90
    And down
     
  11. BoxcabE50

    BoxcabE50 Staff Member TrainBoard Supporter

    60,274
    4,876
    650
    :eek::eek::eek:
     
  12. Hardcoaler

    Hardcoaler TrainBoard Member

    4,454
    7,786
    78
    If the problem is tied to the immense size of the database, is there a way to have the search function ignore a portion of the oldest posts? I'm thinking that I'd rather be able to search for newer posts only than not be able to search at all. (I don't know anything about databases! :confused:)
     
  13. bremner

    bremner Staff Member

    5,211
    2,852
    90
    It might be a software problem, or the size of the DB....the problem with a table as large as the posts is that you have to query it for every post. In all honesty, I am surprised that the site loads as fast as it does. Also, there's no way to limit the search to a timeframe.
     
    Hardcoaler likes this.
  14. bremner

    bremner Staff Member

    5,211
    2,852
    90
    10:16 Mountain Time and the search works....I made no changes...
     
    Hardcoaler likes this.
  15. gjslsffan

    gjslsffan Staff Member

    1,595
    1,917
    44
    02:07 MST search bar working here too.
     
  16. BoxcabE50

    BoxcabE50 Staff Member TrainBoard Supporter

    60,274
    4,876
    650
    Just used it. Worked fine.
     
  17. bremner

    bremner Staff Member

    5,211
    2,852
    90
    And it failed at 8:34 AM MST
     
  18. BoxcabE50

    BoxcabE50 Staff Member TrainBoard Supporter

    60,274
    4,876
    650
    This is beginning to remind me about a glitch we had, with the old software. :(
     
  19. BoxcabE50

    BoxcabE50 Staff Member TrainBoard Supporter

    60,274
    4,876
    650
    Just used it to find a topic from last summer. Worked just fine for me.
     
  20. vasilis

    vasilis TrainBoard Member

    105
    37
    6
    it works
     

Share This Page